Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation 1.5.4.1 sur Gutsy 64 .... erreur libdbus-glib
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
[Locked] 1.5.4.1 sur Gutsy 64 .... erreur libdbus-glib
Tdey Français 14 The_Moye [Read]
13 April 2008 à 10:52

Tdey, Sunday 06 April 2008 à 15:24


Subscription date : 29 November 2007
Messages : 333
Coucou,

Et un petit "bug" un !
Pour la version "stable" 1.5.4.1, pas de message à l'installation, mais au lancement du dock il y'a ça dans le terminal:

cairo-dock: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory


Il me semble qu'on avait déjà eu un souci de ce gencre il y a quelques versions, non ?

fabounet, Monday 07 April 2008 à 03:46


Subscription date : 30 November 2007
Messages : 17118
grumpf, ça commence à être lourd ce DBus !
tu es sous Hardy ou Gutsy (ou autre ) ?

Tdey, Monday 07 April 2008 à 16:14


Subscription date : 29 November 2007
Messages : 333
Ah désolé de la réponse tardive, je suis sous Gutsy là, mais ce qui m'étonne, c'est que je n'ai pas de souci avec le svn.

fabounet, Monday 07 April 2008 à 16:23


Subscription date : 30 November 2007
Messages : 17118
hmm, que te donne ls -l /usr/lib/libdbus* ?

Tdey, Monday 07 April 2008 à 16:27


Subscription date : 29 November 2007
Messages : 333
Voilà Maitre

-rw-r--r-- 1 root root 585196 2007-10-05 15:28 /usr/lib/libdbus-1.a
lrwxrwxrwx 1 root root 18 2007-11-10 19:04 /usr/lib/libdbus-1.so -> libdbus-1.so.3.3.0
lrwxrwxrwx 1 root root 18 2007-11-08 20:54 /usr/lib/libdbus-1.so.3 -> libdbus-1.so.3.3.0
-rw-r--r-- 1 root root 244072 2007-10-05 15:28 /usr/lib/libdbus-1.so.3.3.0
-rw-r--r-- 1 root root 238450 2007-07-06 18:46 /usr/lib/libdbus-glib-1.a
lrwxrwxrwx 1 root root 23 2008-04-06 15:29 /usr/lib/libdbus-glib-1.so -> libdbus-glib-1.so.2.1.0
lrwxrwxrwx 1 root root 23 2008-04-06 15:27 /usr/lib/libdbus-glib-1.so.2 -> libdbus-glib-1.so.2.1.0
-rw-r--r-- 1 root root 131880 2007-07-06 18:47 /usr/lib/libdbus-glib-1.so.2.1.0
lrwxrwxrwx 1 root root 21 2007-11-08 22:26 /usr/lib/libdbus-qt-1.so.1 -> libdbus-qt-1.so.1.0.0
-rw-r--r-- 1 root root 74664 2007-03-05 11:56 /usr/lib/libdbus-qt-1.so.1.0.0

Guest, Friday 11 April 2008 à 16:52

Salut la populace =)

Je me permets de poster car j'ai exactement le même soucis!
As tu trouver comment le régler Tdey ?

Je copie le résultat de ls -l /usr/lib/libdbus*

lrwxrwxrwx 1 root root 18 2008-04-11 12:51 /usr/lib/libdbus-1.so.3 -> libdbus-1.so.3.3.0
-rw-r--r-- 1 root root 244072 2007-10-05 15:28 /usr/lib/libdbus-1.so.3.3.0
lrwxrwxrwx 1 root root 23 2008-04-11 12:51 /usr/lib/libdbus-glib-1.so.2 -> libdbus-glib-1.so.2.1.0
-rw-r--r-- 1 root root 131880 2007-07-06 18:47 /usr/lib/libdbus-glib-1.so.2.1.0

The_Moye, Friday 11 April 2008 à 16:54


Subscription date : 11 April 2008
Messages : 25
C'est encore moi, oubli de log ^o^

Et je précise que je viens de DL la 1.5.4.2 , et que je suis aussi sur Gutsy 64!

fabounet, Friday 11 April 2008 à 18:12


Subscription date : 30 November 2007
Messages : 17118
et bien malheureusement tout ça ne nous aide pas
je vois bien des "libdbus-glib-1.so.2" dans vos dossiers, ils sont lisibles, donc je vois pas ce qui cloche !
Tdey tu es aussi en 64bits ? vous avez installé à partir des paquets 32 bits ?
si oui avec quelle méthode ?

The_Moye, Friday 11 April 2008 à 18:35


Subscription date : 11 April 2008
Messages : 25
Merci de ta reponse fabounet

Oui c'est installé a partir des paquets 32bits.
J'ai suivi la méthode "pour les processeurs 64bits" du wiki.

Et la commande pour chopper les lib manquantes (getlibs -l nomlib) ne fait rien pour ibdbus-glib-1.so.2
Autant les précédentes lib qui me manquait pour exécuter cairo ont été téléchargées correctement, mais celle ci ne semble même pas vouloir se re-télécharger.

fabounet, Friday 11 April 2008 à 18:39


Subscription date : 30 November 2007
Messages : 17118
si tu essayes d'installer la version de dev de cette lib ? (même nom mais avec -dev à la fin)

The_Moye, Friday 11 April 2008 à 19:15


Subscription date : 11 April 2008
Messages : 25
Il ne risque pas d'avoir de problème de compatibilité ?
Et pour l'installer, je suis la même tactique?J'utilise getlibs?

fabounet, Saturday 12 April 2008 à 04:54


Subscription date : 30 November 2007
Messages : 17118
non pas de problème,
je sais pas si tu utilises getlibs par contre ^_^ suis pas un pro du 64bits, je dirais de passer par Synaptic mais je sais même pas ce que ça change.

The_Moye, Saturday 12 April 2008 à 11:01


Subscription date : 11 April 2008
Messages : 25
Bonjour Bonjour!

Résolu pour moi!
Un grand merci a McPeter (du tchat irc.freenode.net, #Ubuntu-fr), qui m'a grandement conseillé =D

Donc, la marche que j'ai suivi, tout d'abord dans un terminale, (apres avoir suivi le tuto "processeurs 64bits Ubuntu") l'exécution de la commande cairo-dock me retournait
cairo-dock: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory

J'appel à la commande getlibs -l libdbus-glib-1.so.2 ne faisait rien (pas de téléchargement, pas de retour dans la console, rien!)
Suite aux conseils de McPeter, j'ai tapé la commande suivante (du tuto "SVN instables") :
sudo apt-get install subversion libtool build-essential automake1.9 autoconf m4 autotools-dev pkg-config libcairo2-dev libgtk2.0-dev librsvg2-dev libglitz1-dev libcairo2 librsvg2-2 libglitz1 libglitz-glx1 libglitz-glx1-dev libdbus-glib-1-dev libgnomeui-dev zenity intltool gettext libvte-dev libxxf86vm-dev libx11-dev libalsa-ocaml libalsa-ocaml-dev libasound2-dev

Ce qui m'a installé pour 82Mo de packages.
Suite a cette commande, getlibs -l libdbus-glib-1.so.2 a reussi a télécharger la lib qu'il ne trouvait pas.
Deux autres lib manquaient à l'appel, un appel a getlibs a suffit a les telecharger.

Et maintenant Cairo-dock fonctionne niquel x)

Le lancement au démarrage (sous Gutsy, et compiz fuzion) marche niquel, sur toutes les faces du cube, sans avoir besoin du .sh lui disant d'attendre que compiz ne soit lancé!

Un grand bravo à l'équipe de Cairo-Dock, ça rend vraiment bien

fabounet, Sunday 13 April 2008 à 04:52


Subscription date : 30 November 2007
Messages : 17118
c'est de la magie, mais ça aurait ptet ça place dans le wiki, rubrique "Harry Poter" non ?

The_Moye, Sunday 13 April 2008 à 10:52


Subscription date : 11 April 2008
Messages : 25
Harry Potter n'y est pour rien fabounet, c'est Chuck Norris qu'il faut remercier

Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
[Locked] 1.5.4.1 sur Gutsy 64 .... erreur libdbus-glib
Tdey Français 14 The_Moye [Read]
13 April 2008 à 10:52


Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation 1.5.4.1 sur Gutsy 64 .... erreur libdbus-glib Top

Online users : derispaka25,

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.