Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Git Version | Version Git Errors using bzr shell script
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Git Version | Version Git

Subjects Author Language Messages Last message
[Locked] Errors using bzr shell script
howudodat English 13 matttbe [Read]
11 December 2013 à 18:43

howudodat, Monday 09 December 2013 à 19:59


Subscription date : 08 December 2013
Messages : 11
Before I go and install the missing libraries I wanted to post the errors from cairo-dock_bzr.sh in case their is either already a fix or so they can be fixed.

History: just as a bit of history, I have the double character problem described here: https://glx-dock.org/bg_topic.php?t=7219. So I am compiling cairo-dock from source since the weekly ubuntu ppa only supports gtk 3.8.

After following the instructions here:http://glx-dock.org/ww_page.php?p=By%20compiling&lang=en
I am using the instructions specifically for debian / ubuntu and the script. What wasn't clear was whether or not the dependencies still needed to be installed given this line:
Moreover, the script will automatically install all the packages necessary for the compilation.


The script bombed with all sorts of errors. Attached is the log

Should I go off and install all the dependencies or should there be a fix for the script or did I just blow it somehow.

Peter
PS. While I am a software developer for 26+ years, I currently dont have the personal bandwidth to debug the source on this. I am only doing this because I cant seem to find a binary compiled against GTK3.10

LogFile:
Installation de Cairo-Dock du Mon Dec 9 10:25:47 PST 2013

-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- checking for modules 'glib-2.0;gthread-2.0;cairo;librsvg-2.0;dbus-1;dbus-glib-1;libxml-2.0;gl;glu;libcurl'
-- found glib-2.0, version 2.38.2
-- found gthread-2.0, version 2.38.2
-- found cairo, version 1.12.16
-- found librsvg-2.0, version 2.40.0
-- found dbus-1, version 1.6.12
-- found dbus-glib-1, version 0.100.2
-- found libxml-2.0, version 2.9.1
-- found gl, version 10.0.0
-- found glu, version 9.0.0
-- found libcurl, version 7.32.0
-- checking for module 'x11'
-- found x11, version 1.6.1
-- Looking for glXMakeCurrent in GL
-- Looking for glXMakeCurrent in GL - found
-- checking for modules 'xtst;xcomposite;xrandr;xrender'
-- package 'xcomposite' not found
-- package 'xrandr' not found
-- checking for module 'gtk+-3.0'
-- package 'gtk+-3.0' not found
-- checking for module 'gtk+-2.0'
-- package 'gtk+-2.0' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
CMakeLists.txt:140 (pkg_check_modules)

-- Looking for encrypt in crypt
-- Looking for encrypt in crypt - found
-- Looking for LC_MESSAGES
-- Looking for LC_MESSAGES - found
-- Looking for include file math.h
-- Looking for include file math.h - found
-- Looking for sin in m
-- Looking for sin in m - found
-- Looking for include file dlfcn.h
-- Looking for include file dlfcn.h - found
-- Looking for dlopen in dl
-- Looking for dlopen in dl - found
-- Looking for libintl_gettext in intl
-- Looking for libintl_gettext in intl - not found
CMake Error at src/gldit/CMakeLists.txt:72 (if):
if given arguments:

"GREATER" "3" "OR" "(" "EQUAL" "3" "AND" "GREATER" "8" ")"

Unknown arguments specified

-- Configuring incomplete, errors occurred!

Installation des plug-ins du Mon Dec 9 10:25:50 PST 2013

/opt/cairo-dock_bzr
/opt/cairo-dock_bzr/cairo-dock-plug-ins
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- checking for module 'gldi=3.3.99.alpha1'
-- package 'gldi=3.3.99.alpha1' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
CMakeLists.txt:52 (pkg_check_modules)

Package gldi was not found in the pkg-config search path.
Perhaps you should add the directory containing `gldi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gldi' found
CMake Error at CMakeLists.txt:60 (MESSAGE):
Error: version mismatch with the core: 3.3.99.alpha1 <>

-- Configuring incomplete, errors occurred!

-e This package libxslt1-dev isn't installed : Installation
-e This package xclip isn't installed : Installation
-e This package rubygems isn't installed : Installation
Selecting previously unselected package libruby1.8.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 400807 files and directories currently installed.)
Unpacking libruby1.8 (from .../libruby1.8_1.8.7.358-7ubuntu2.1_amd64.deb) ...
Selecting previously unselected package libxslt1-dev:amd64.
Unpacking libxslt1-dev:amd64 (from .../libxslt1-dev_1.1.28-2_amd64.deb) ...
Selecting previously unselected package ruby1.8.
Unpacking ruby1.8 (from .../ruby1.8_1.8.7.358-7ubuntu2.1_amd64.deb) ...
Selecting previously unselected package ruby1.8-dev.
Unpacking ruby1.8-dev (from .../ruby1.8-dev_1.8.7.358-7ubuntu2.1_amd64.deb) ...
Selecting previously unselected package rubygems.
Unpacking rubygems (from .../rubygems_1.8.24-1ubuntu2_all.deb) ...
Selecting previously unselected package xclip.
Unpacking xclip (from .../xclip_0.12+svn84-2_amd64.deb) ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db ...
Setting up libruby1.8 (1.8.7.358-7ubuntu2.1) ...
Setting up libxslt1-dev:amd64 (1.1.28-2) ...
Setting up ruby1.8 (1.8.7.358-7ubuntu2.1) ...
Setting up ruby1.8-dev (1.8.7.358-7ubuntu2.1) ...
Setting up rubygems (1.8.24-1ubuntu2) ...
Setting up xclip (0.12+svn84-2) ...
Processing triggers for libc-bin ...
error: Package `CDApplet' not found in specified Vala API directories or GObject-Introspection GIR directories
Successfully installed parseconfig-1.0.2
Successfully installed addressable-2.3.5
Successfully installed launchy-2.4.2
Building native extensions. This could take a while...
Successfully installed ruby-dbus-0.9.2
4 gems installed
Installing ri documentation for parseconfig-1.0.2...
Installing ri documentation for addressable-2.3.5...
Installing ri documentation for launchy-2.4.2...
Installing ri documentation for ruby-dbus-0.9.2...
Installing RDoc documentation for parseconfig-1.0.2...
Installing RDoc documentation for addressable-2.3.5...
Installing RDoc documentation for launchy-2.4.2...
Installing RDoc documentation for ruby-dbus-0.9.2...
Installation des Plug-ins Extras du Mon Dec 9 10:27:18 PST 2013

Installation de Cairo-Desklet

-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- checking for module 'gldi'
-- package 'gldi' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
CMakeLists.txt:57 (pkg_check_modules)

-- Looking for include file math.h
-- Looking for include file math.h - found
-- Looking for LC_MESSAGES
-- Looking for LC_MESSAGES - found
-- Looking for sin in m
-- Looking for sin in m - found
-- Configuring incomplete, errors occurred!

matttbe, Monday 09 December 2013 à 21:03


Subscription date : 24 January 2009
Messages : 12573
Hello,

It seems it doesn't found development files (.h, .pc, etc.) of GTK 3.
How did you installed GTK? What's the output messages produced by these commands launched from a terminal?
pkg-config --variable=prefix gtk+-3.0
pkg-config --print-requires gtk+-3.0
ls /usr/include/gtk-3.0
locate include/gtk-3.0


Note that the script will try to install libgtk-3-dev but it's maybe a problem for you. If it is, you can edit this line to avoid any update of this script:
DEBUG=0
to
DEBUG=1

And then removed libgtk-3-dev from NEEDED_A_NATTY="(...)". But note that it's possible that another package also needs libgtk-3-dev and will try to install it!

PS: I just added xcomposite and xrandr dependences. Can you relaunch the script to install them? (it can take time, don't stop the script )

howudodat, Monday 09 December 2013 à 21:19


Subscription date : 08 December 2013
Messages : 11
gtk+-3.0 definitely is NOT installed.
peter@OFFICE ~ pkg-config --variable=prefix gtk+-3.0
peter@OFFICE ~ pkg-config --print-requires gtk+-3.0
peter@OFFICE ~ ls /usr/include/gtk-3.0
ls: cannot access /usr/include/gtk-3.0: No such file or directory
peter@OFFICE ~ locate include/gtk-3.0


Not sure why the script is not installing it, is there a debug for that, or should I install it manually? If so, what particular package do you need?

here is how I installed GTK 3.10
sudo add-apt-repository ppa:gnome3-team/gnome3-next
sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get update
sudo apt-get dist-upgrade

Peter

matttbe, Monday 09 December 2013 à 22:37


Subscription date : 24 January 2009
Messages : 12573
Not sure why the script is not installing it
Yes, it's strange!
Can you edit the script? First change DEBUG=0 to DEBUG=1, then add
echo $NEEDED
at the line 1083 (before for tested in $NEEDED) and
echo $packetsOK
at the line 1102 (before sudo apt-get install -y --force-yes -m -qq $paquetsOK)

The script should try to install libgtk-3-dev.
apt-cache policy libgtk-3-dev

howudodat, Monday 09 December 2013 à 23:28


Subscription date : 08 December 2013
Messages : 11
ok, below are the results. I also included a quick copy/paste of the script to assure you I did ok

code:
    paquetsOK=""
echo ==========================================NEEDED====================================
echo $NEEDED
echo ==========================================NEEDED====================================
    for tested in $NEEDED
    do
        dpkg -s $tested |grep installed |grep "install ok" > /dev/null
        if [ $? -eq 1 ]; then
            echo -e "$ROUGE""This package $tested isn't installed : Installation""$NORMAL"""
            paquetsPresent="$paquetsPresent $tested"
            # sudo apt-get install -qq $tested >> $LOG_CAIRO_DOCK
        fi
    done

    for testPkg in $paquetsPresent; do
        sudo apt-get install -s $testPkg > /dev/null 2>&1
        if [ $? -eq 0 ]; then
            paquetsOK="$paquetsOK $testPkg"
        else
            echo -e "$ROUGE""This package $testPkg isn't available""$NORMAL"""
        fi
    done
echo ==========================================PACKETSOK====================================
echo $paquetsOK
echo ==========================================PAKCETSOK====================================
    sudo apt-get install -y --force-yes -m -qq $paquetsOK


Output:
What's your distribution
Your distribution is "Ubuntu 13.10" (saucy)

What's your DE (Desktop Environment)
Your Desktop Environment is GNOME

Check up: Packages needed for the compilation
==========================================NEEDED====================================
bzr build-essential pkg-config zenity gettext libcairo2-dev librsvg2-dev libdbus-glib-1-dev libgnomeui-dev libxxf86vm-dev x11proto-xf86vidmode-dev libxrandr-dev libxcomposite-dev libxrender-dev libasound2-dev libxtst-dev libetpan-dev libexif-dev curl libglib2.0-dev cmake libcurl4-gnutls-dev libical-dev gdb libsensors4-dev libpulse-dev python valac ruby libxklavier-dev libdbusmenu-glib-dev libupower-glib-dev mono-gmcs libglib2.0-cil-dev libndesk-dbus1.0-cil-dev libndesk-dbus-glib1.0-cil-dev libzeitgeist-dev libgtk-3-dev libgl1-mesa-dev libglu1-mesa-dev libpango1.0-dev libdbusmenu-gtk3-dev libido3-0.1-dev libindicator3-dev libwebkitgtk-3.0-dev libvte-2.90-dev libgnome-menu-3-dev
==========================================NEEDED====================================
dpkg-query: package 'libgnomeui-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libgnomeui-dev isn't installed : Installation
dpkg-query: package 'libdbusmenu-glib-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libdbusmenu-glib-dev isn't installed : Installation
dpkg-query: package 'libgtk-3-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libgtk-3-dev isn't installed : Installation
dpkg-query: package 'libpango1.0-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libpango1.0-dev isn't installed : Installation
dpkg-query: package 'libdbusmenu-gtk3-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libdbusmenu-gtk3-dev isn't installed : Installation
dpkg-query: package 'libido3-0.1-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libido3-0.1-dev isn't installed : Installation
dpkg-query: package 'libindicator3-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libindicator3-dev isn't installed : Installation
dpkg-query: package 'libwebkitgtk-3.0-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libwebkitgtk-3.0-dev isn't installed : Installation
dpkg-query: package 'libvte-2.90-dev' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
This package libvte-2.90-dev isn't installed : Installation
This package libgnomeui-dev isn't available
This package libdbusmenu-glib-dev isn't available
This package libgtk-3-dev isn't available
This package libpango1.0-dev isn't available
This package libdbusmenu-gtk3-dev isn't available
This package libido3-0.1-dev isn't available
This package libindicator3-dev isn't available
This package libwebkitgtk-3.0-dev isn't available
This package libvte-2.90-dev isn't available
==========================================PACKETSOK====================================

==========================================PAKCETSOK====================================
Verification [ OK ]

Check if there is an update for Cairo-Dock

Cairo-Dock-Core : rev 1687 -> 1687

matttbe, Monday 09 December 2013 à 23:44


Subscription date : 24 January 2009
Messages : 12573
This package libdbusmenu-glib-dev isn't available
This package libgtk-3-dev isn't available
This package libpango1.0-dev isn't available
This package libdbusmenu-gtk3-dev isn't available
This package libido3-0.1-dev isn't available
This package libindicator3-dev isn't available
This package libwebkitgtk-3.0-dev isn't available
This package libvte-2.90-dev isn't available

This is strange! What's the output messages produced by these commands?
apt-cache policy libgtk-3-dev
sudo apt-get install libgtk-3-dev

howudodat, Tuesday 10 December 2013 à 00:29


Subscription date : 08 December 2013
Messages : 11
interesting
peter@OFFICE /opt/cairo-dock_bzr apt-cache policy libgtk-3-dev
libgtk-3-dev:
Installed: (none)
Candidate: 3.10.6-0ubuntu1~~saucy1
Version table:
3.10.6-0ubuntu1~~saucy1 0
500 http://ppa.launchpad.net/gnome3-team/gnome3-next/ubuntu/ saucy/main amd64 Packages
500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/ saucy/main amd64 Packages
3.8.6-0ubuntu3 0
500 http://us.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
3.8.4-0ubuntu3 0
500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
peter@OFFICE /opt/cairo-dock_bzr ^C
peter@OFFICE /opt/cairo-dock_bzr sudo apt-get install libgtk-3-dev
[sudo] password for peter:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk-3-dev : Depends: libpango1.0-dev (>= 1.32.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I battled this before on a different system with labpango, but I can't seem to remember what I did

Peter

matttbe, Tuesday 10 December 2013 à 12:30


Subscription date : 24 January 2009
Messages : 12573
Can you reload the packages list
sudo apt-get update

and check which version of libpango is available?
apt-cache policy libpango1.0-dev
sudo apt-get install libpango1.0-dev

howudodat, Tuesday 10 December 2013 à 17:26


Subscription date : 08 December 2013
Messages : 11
ok, I followed all the packages down to the one that I think is broken:
peter@OFFICE /opt/cairo-dock_bzr apt-cache policy libpango1.0-dev
libpango1.0-dev:
Installed: (none)
Candidate: 1.36.0-1ubuntu1~saucy1
Version table:
1.36.0-1ubuntu1~saucy1 0
500 http://ppa.launchpad.net/gnome3-team/gnome3-next/ubuntu/ saucy/main amd64 Packages
500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/ saucy/main amd64 Packages
1.32.5-5ubuntu1 0
500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
peter@OFFICE /opt/cairo-dock_bzr sudo apt-get install libpango1.0-dev
[sudo] password for peter:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpango1.0-dev : Depends: libharfbuzz-dev (>= 0.9.9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
peter@OFFICE /opt/cairo-dock_bzr sudo apt-get install libharfbuzz-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libharfbuzz-dev : Depends: libharfbuzz0a (= 0.9.19-1) but 0.9.20-0ubuntu1~13.04~ricotz1 is to be installed
E: Unable to correct problems, you have held broken packages.
peter@OFFICE /opt/cairo-dock_bzr sudo apt-get install libharfbuzz0a
Reading package lists... Done
Building dependency tree
Reading state information... Done
libharfbuzz0a is already the newest version.
libharfbuzz0a set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
peter@OFFICE /opt/cairo-dock_bzr apt-cache policy libharfbuzz0a
libharfbuzz0a:
Installed: 0.9.20-0ubuntu1~13.04~ricotz1
Candidate: 0.9.20-0ubuntu1~13.04~ricotz1
Version table:
*** 0.9.20-0ubuntu1~13.04~ricotz1 0
100 /var/lib/dpkg/status
0.9.19-1 0
500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages


Peter

matttbe, Tuesday 10 December 2013 à 22:54


Subscription date : 24 January 2009
Messages : 12573
Please report this bug to Gnome3 Team

howudodat, Wednesday 11 December 2013 à 06:59


Subscription date : 08 December 2013
Messages : 11
ok, I think I got everything installed - here is the current build log

What do you want :

    1 --> Update Cairo-Dock to the latest BZR revision
    2 --> Reinstall the current version
    3 --> Uninstall the current version
    4 --> Install weekly ppa instead of BZR
    5 --> Display the current installed revision
    6 --> About this script

Your choice :
1
What's your distribution
Your distribution is "Ubuntu 13.10" (saucy)

What's your DE (Desktop Environment)
Your Desktop Environment is GNOME

Check up: Packages needed for the compilation
==========================================NEEDED====================================
bzr build-essential pkg-config zenity gettext libcairo2-dev librsvg2-dev libdbus-glib-1-dev libgnomeui-dev libxxf86vm-dev x11proto-xf86vidmode-dev libxrandr-dev libxcomposite-dev libxrender-dev libasound2-dev libxtst-dev libetpan-dev libexif-dev curl libglib2.0-dev cmake libcurl4-gnutls-dev libical-dev gdb libsensors4-dev libpulse-dev python valac ruby libxklavier-dev libdbusmenu-glib-dev libupower-glib-dev mono-gmcs libglib2.0-cil-dev libndesk-dbus1.0-cil-dev libndesk-dbus-glib1.0-cil-dev libzeitgeist-dev libgtk-3-dev libgl1-mesa-dev libglu1-mesa-dev libpango1.0-dev libdbusmenu-gtk3-dev libido3-0.1-dev libindicator3-dev libwebkitgtk-3.0-dev libvte-2.90-dev libgnome-menu-3-dev
==========================================NEEDED====================================
==========================================PACKETSOK====================================

==========================================PAKCETSOK====================================
Verification [ OK ]

Check if there is an update for Cairo-Dock

Cairo-Dock-Core : rev 1687 -> 1687

Check if there is an update for Plug-ins

Cairo-Dock-Plug-Ins : rev 3022 -> 3022

Check if there is an update for Plug-ins Extras

Cairo-Dock-Plug-Ins-Extras : rev 449 -> 449

Check if there is an update for Desklets

Cairo-Desklet : rev 32 -> 32

No update available

(zenity:8068): Gtk-WARNING **: Error setting gtk-primary-button-warps-slider in /home/peter/.config/gtk-3.0/settings.ini: Key file contains key 'gtk-primary-button-warps-slider' which has a value that cannot be interpreted.

(zenity:8068): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:17: Theming engine 'unico' not found
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 14: out of memory
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 23: out of memory
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 32: out of memory

matttbe, Wednesday 11 December 2013 à 13:03


Subscription date : 24 January 2009
Messages : 12573
If everything is installed, use the second option of this script to recompile the latest version

howudodat, Wednesday 11 December 2013 à 16:52


Subscription date : 08 December 2013
Messages : 11
ok, I have my dock back yay! The double character is fixed as well, however I have some new problems. Let me know if you want me to move these to a new thread.

The application menu doesn't draw correctly. Actually no menu does (see the black corners around the menu).
However when I click on the app menu icon, it loads the menu all the way to the bottom of my screen - and then when the mouse moves, it jumps up (see difference between screen1 and screen2)

hmmm. I dont see how to upload an image or attache a file, so they can be found here:
http://www.earthbest.com/screen1.png http://www.earthbest.com/screen2.png

Running cairo from a terminal produces this output:
peter@OFFICE ~ cairo-dock

(cairo-dock:7101): Gtk-WARNING **: Error setting gtk-primary-button-warps-slider in /home/peter/.config/gtk-3.0/settings.ini: Key file contains key 'gtk-primary-button-warps-slider' which has a value that cannot be interpreted.

(cairo-dock:7101): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:17: Theming engine 'unico' not found
warning : (/opt/cairo-dock_bzr/cairo-dock-core/src/implementations/cairo-dock-glx.c:_initialize_opengl_backend:179)
couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

============================================================================
    Cairo-Dock version : 3.3.99.alpha1
    Compiled date : Dec 11 2013 06:45:00
    Built with GTK : 3.10
    Running with OpenGL: 1
============================================================================

style changed
warning : (/opt/cairo-dock_bzr/cairo-dock-plug-ins/Dbus/src/applet-dbus.c:cd_dbus_register_module_in_dir:176)
file /home/peter/.config/cairo-dock/third-party/po/auto-load.conf should not be here
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 14: out of memory
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 23: out of memory
Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 32: out of memory
Cairo-Dock - Launcher API Daemon is already running (3487)
cairo_dock_create_surface_from_xpixmap: assertion 'Xid > 0' failed
cairo_dock_redraw_icon: assertion 'pContainer != NULL' failed
_init_menu_style (2)
style changed ignored
style changed ignored
margin position: -1 -> 0
+ css
margin position: -1 -> 0
+ css
margin position: -1 -> 0
+ css
margin position: -1 -> 0
+ css
gtk_device_grab_add: assertion 'GDK_IS_DEVICE (device)' failed
margin position: -1 -> 0
+ css
gtk_device_grab_add: assertion 'GDK_IS_DEVICE (device)' failed


However no errors are shown when I click on the application menu.

Peter

matttbe, Wednesday 11 December 2013 à 18:43


Subscription date : 24 January 2009
Messages : 12573
Great

Let me know if you want me to move these to a new thread.
Yes it's maybe better!

The application menu doesn't draw correctly. Actually no menu does (see the black corners around the menu).
Do you have any composite manager running? What's your desktop environment (Gnome?), your session that you're using (Gnome-Shell?) and your window manager (Mutter?)?

Git Version | Version Git

Subjects Author Language Messages Last message
[Locked] Errors using bzr shell script
howudodat English 13 matttbe [Read]
11 December 2013 à 18:43


Glx-Dock / Cairo-Dock List of forums Git Version | Version Git Errors using bzr shell script Top

Online users :

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.