Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation Installation problem for newbie without Internet connection
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
Installation problem for newbie without Internet connection
Page : 1 2
Sadeck English 21 Guest [Read]
29 November 2013 à 15:20

Sadeck, Thursday 17 December 2009 à 09:04 | Quote


Subscription date : 11 December 2009
Messages : 2
Hi I am a complete newbie does anyone know how to install cairo-dock step by step within linux mint 8 without an Internet connection?

Thank you.


matttbe, Thursday 17 December 2009 à 15:30 | Quote


Subscription date : 24 January 2009
Messages : 12573
Hi

without an Internet connection

Mmh, you can download all packages named Cairo-Dock-* but it needs some dependences !
But I've an idea

  • Launch this command in a terminal
    uname -m
    You will have something like i386, amd64 or lpia => it's your architecture (Arch)
  • Go to a computer with an Internet connexion and a USB stick
    • Read this http://www.webupd8.org/2009/12/sushi-huh-easily-download-packages-for.html
    • Use the package 'cairo-dock' for Ubuntu Karmic 9.10 (version 9, release 10)
    • After having downloaded all packages on your USB stick, copy the repertory 'download' from 'sushi-huh/src/' of your USB stick to your computer (for example in the repertory 'packages' in your Home)
    • Open a terminal and do that :
      cd ~/packages
      sudo dpkg -i *.deb
    • You should have Cairo-Dock installed . If you have an error, launch this command in a terminal :
      sudo apt-get install -f
      and note all packages that you have to install. Go there : http://packages.ubuntu.com/ and download packages needed to the same repertory ('packages') and redo the previous point.


After that, to have the latest stable release, do that :
  1. Create a repertory in your Home named 'cairo-dock' (for example)
  2. Simply go there : https://launchpad.net/~cairo-dock-team/+archive/ppa/+packages
  3. Click on "cairo-dock - 2.1.2-4-1ubuntu1~karmic", you should see something like :
    cairo-dock-core_2.1.2-4-1ubuntu1~karmic_amd64.deb (855.5 KiB)
    cairo-dock-core_2.1.2-4-1ubuntu1~karmic_i386.deb (816.8 KiB)
    cairo-dock-core_2.1.2-4-1ubuntu1~karmic_lpia.deb (824.8 KiB)
    cairo-dock-data_2.1.2-4-1ubuntu1~karmic_all.deb (712.5 KiB)
    cairo-dock-dev_2.1.2-4-1ubuntu1~karmic_amd64.deb (111.0 KiB)
    cairo-dock-dev_2.1.2-4-1ubuntu1~karmic_i386.deb (116.4 KiB)
    cairo-dock-dev_2.1.2-4-1ubuntu1~karmic_lpia.deb (110.2 KiB)
    cairo-dock_2.1.2-4-1ubuntu1~karmic.dsc (1.3 KiB)
    cairo-dock_2.1.2-4-1ubuntu1~karmic.tar.gz (2.1 MiB)
    cairo-dock_2.1.2-4-1ubuntu1~karmic_all.deb (7.8 KiB)
  4. Click on every 'all.deb' in order to download it in the 'cairo-dock' repertory. (=> 2 packages)
  5. Do the same with all packages adapted to your architecture (i386, amd64 or lpia) (=> 2 packages)
  6. Do the same with "cairo-dock-plug-ins - 2.1.2-4-1ubuntu1~karmic" (=> 1 package 'all' and 2 others)
  7. Open a terminal and launch this commands :
    cd ~/cairo-dock
    sudo dpkg -i *.deb

fabounet, Thursday 17 December 2009 à 16:21 | Quote


Subscription date : 30 November 2007
Messages : 17118
seems like what we did during the Ubuntu Party

matttbe, Thursday 17 December 2009 à 16:33 | Quote


Subscription date : 24 January 2009
Messages : 12573

Sadeck, Friday 18 December 2009 à 08:41 | Quote


Subscription date : 11 December 2009
Messages : 2
Thank you matttbe - from your first step I have found out that my arch is i686.

Also brought my desktop in to hook up to the net ad am having ISA server problems - I very badly really want cairo-dock to work on my box!

I really appreciate the time you took in typing out these steps.


matttbe, Friday 18 December 2009 à 11:51 | Quote


Subscription date : 24 January 2009
Messages : 12573
No problem, it can also be useful for other people

Guest, Wednesday 23 December 2009 à 22:48 | Quote

Bonjour, en premier je dis un GRAND MERCI!!! A

- Fabounet
- Mav
- Tofe
- matttbe
- Jokernathan
- Ours_en_pluche et Lord Northam et tout l'équipe
pour améliorer Cairo-dock... .


j'aimerais installer la version que vous proposez Cairo-dock version 2.1.2-4-1ubuntu... .
Simplifier l'explication: "-> = dépend de"
Malheureusement, le paquet "Cairo-dock-dev" ->"libdbus-glib-1-dev" qui ->"libdbus-1-dev" qui ->"libdbus-1-3(= 1.2.1-5+lenny1)"
que je télécharge sur http://packages.debian.org/lenny/libdbus-1-dev.
J'installe libdbus-1-3(=1.2.1-5+lenny1)
Et HIC! c'est le drame:

Synatic dit: erreur une version plus récente est déja installé!
Alors j'installe directement libdbus-1-dev et mon synatic dit erreur Dépendance non satisfaite : libdbus-1-3(=1.2.1-5+lenny1)

Que faire quoi faire quand on a une version libdbus-1-3(1.2.16-Oubuntu9)?
car si je le désinstalle d'autre paquet seront désinstaller et je préfère avoir l'avie d'un expère.
Car j'ai pas envie de me retrouver avec un greub error : unknown filesystem grub rescue> et devoir reformater surtout que mon disque dur a des secteur déffectueux... .
Car mon coucou date de 4ans alors bonjour pour récupérer les pièces... .

Je suis petit nouveau dans l'univers de Linux depuis 3 semaines mais grace au forum et a vous j'avance doucement...

Actuelle je suis sous(Gnome)Ubuntu9.10AMD64 version du noyau 2.6.31-14-generic et je marche pour le plaisir d'apprendre sur Cairo-Dock version 2.0.9:
-Tout marche impeccable en mode sans Opengl! Good!!! ;-D
-Mais pas en mode Opengl. (enfin pas pour l'instant ^^)

je répète ma question entre tout ses lignes ^^:
Que faire quoi faire quand on a une version libdbus-1-3(1.2.16-Oubuntu9)?

Encore merci et bonne fête de fin d'année !

Guest, Wednesday 23 December 2009 à 23:07 | Quote

a oui oups j'ai oublier : uname -m
x86_64

matttbe, Wednesday 23 December 2009 à 23:16 | Quote


Subscription date : 24 January 2009
Messages : 12573
Simply don't install all -dev packages . This package is mainly useful for package cairo-dock-plug-ins .

If you search other deb packages for Ubuntu (or linux mint -> Linux Mint 8 = Ubuntu Karmic 9.10), go there : http://packages.ubuntu.com/ and download all packages needed.

EDIT : en français : Il n'est pas nécessaire d'installer les paquets -dev qui sont principalement utiles pour packager cairo-dock-plug-ins.
Si vous cherchez d'autres paquets pour Ubuntu ou linux mint -> Linux Mint 8 = Ubuntu Karmic 9.10), aller là : http://packages.ubuntu.com/ et téléchargez tous lez paquets dont vous avez besoin.

nochka85, Wednesday 23 December 2009 à 23:17 | Quote


Subscription date : 29 November 2007
Messages : 7408
Je suis pas dans la liste alors je ne reponds pas ...

Guest, Thursday 24 December 2009 à 00:39 | Quote

Bonsoire, sisi nochka85 tu est a la 7èmes ligne juste après "Ours_en_pluche et Lord Northam et" dans "tout l'équipe" :-b mais je suis comptant que tu es réagis a mon annonce^^

Thank matttbe but already i'have download all.

My problems it's with synaptic say you must setup libdbus-1-3(= 1.2.1-5+lenny1)
as libdbus-glib-1-2(= 0.76-1).

In my Operating System i've already libdbus-1-3(1.2.16-Oubuntu9) and libdbus-glib-1-2 (= 0.80-4ubuntu1)
while i must setup libdbus-1-3(=1.2.1-5+lenny1) and libdbus-glib-1-2(= 0.76-1).
For setup Cairo-dock version 2.1.2-4-1ubuntu

[in french]
Merci matttbe mais j'ai déjas tous télécharger.

Mon soucie c'est que synaptic dit que je dois installer libdbus-1-3(= 1.2.1-5+lenny1)
comme pour libdbus-glib-1-2(= 0.76-1).
Dans mon Ubuntu j'ai déjas installer par défaut libdbus-1-3(1.2.16-Oubuntu9) et libdbus-glib-1-2(= 0.80-4ubuntu1)
alors qu'il faut obligatoirement installer libdbus-1-3(=1.2.1-5+lenny1) and libdbus-glib-1-2(= 0.76-1)
Pour installer Cairo-dock version 2.1.2-4-1ubuntu

I'm sorry, if i write and speak lite bite.
thank you again for you time!

Alors nochka85 une idée ? ^^

Guest, Thursday 24 December 2009 à 01:44 | Quote

Merci Matttbe, j'ai compris que c'est pas obliger d'installer cairo-dock-dev_2.1.2-4-
j'avous je suis un boulet ^^... .

Mais le cairo-dock-plug-ins comment l'installer ? Est-il remplacer par le projet Plug-ins Extras ? je suis fatiguer et j'ai la tête gros comme une citrouille lol

Ce qui veut dire que si j'installe pas Cairo-dock-dev sur mon Cairo-dock_2.1.2-4 je pourrais pue avoir des
applets (plug-ins) détachables du dock en desklets (widgets) ?

En tout cas vous êtes tous fort sympatique!

matttbe, Thursday 24 December 2009 à 01:49 | Quote


Subscription date : 24 January 2009
Messages : 12573
Mmh, it's strange . If you've downloaded packages from ppa or CD repository, cairo-dock-core needs libdbus-1-3 (>= 1.0.2) and libdbus-glib-1-2 (>= 0.78). Your version is newer .

Can you launch this command in a terminal :
sudo apt-get install -f
and post the output ?

Guest, Thursday 24 December 2009 à 02:00 | Quote

ok thank you, i go download ppa or CD... . i come backe

matttbe, Thursday 24 December 2009 à 02:06 | Quote


Subscription date : 24 January 2009
Messages : 12573
Sorry I didn't see your last post

Mais le cairo-dock-plug-ins comment l'installer ?
With deb packages

Est-il remplacer par le projet Plug-ins Extras ?
No, this is a other project (external applets coded in other languages than C)

Ce qui veut dire que si j'installe pas Cairo-dock-dev sur mon Cairo-dock_2.1.2-4 je pourrais pue avoir des
applets (plug-ins) détachables du dock en desklets (widgets) ?
No, cairo-dock-dev is only used by packagers in order to package plug-ins . You don't need this -dev package to use Cairo-Dock.

ok thank you, i go download ppa or CD... . i come backe


In fact, do you prefer that I answer in English or French
En fait, préfères-tu que je réponde en anglais ou en français ?

Guest, Thursday 24 December 2009 à 04:21 | Quote

L'anglais ne me dérange point je suis juste très très long a la détante pour Traduire et me fair comprendre...

Donc les lien que tu m'as donner il sont très sympatic mais le souci c'est que ces paquets dépande tous du même paquetage voicie la réponce de

post the output : dpkg -i *.deb -------j'ai précieusement copier-coller dans le même dossier les 2deb--------

Dépaquetage de cairo-dock-plug-ins-integration (à partir de cairo-dock-plug-ins-integration_2.1.2-4~debian_amd64.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de cairo-dock-plug-ins :
cairo-dock-plug-ins dépend de cairo-dock-plug-ins-data (>= 2.1.2-4~debian) ; cependant :
La version de cairo-dock-plug-ins-data sur le système est 2.0.9-0ubuntu1.
dpkg : erreur de traitement de cairo-dock-plug-ins (--install) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de cairo-dock-plug-ins-integration :
cairo-dock-plug-ins-integration dépend de cairo-dock-plug-ins-data (>= 2.1.2-4~debian) ; cependant :
La version de cairo-dock-plug-ins-data sur le système est 2.0.9-0ubuntu1.
dpkg : erreur de traitement de cairo-dock-plug-ins-integration (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
cairo-dock-plug-ins
cairo-dock-plug-ins-integration

--------END--------------------------
En gros pour simplifié il me manque juste cairo-dock-plug-ins-data (>= 2.1.2-4~debian)
Pour pouvoir les installer ^^

J'ai fait le petit néttoyage comme tu ma dis de fair :
sudo apt-get install -f

je vais chercher ce paquetage 5 minutes sur le web après je vais aller me coucher si je le trouve en première je viens vous le dire ! Promis voili voilou voila Merci Matttbe

matttbe, Thursday 24 December 2009 à 11:32 | Quote


Subscription date : 24 January 2009
Messages : 12573
L'anglais ne me dérange point je suis juste très très long a la détante pour Traduire et me fair comprendre...
Ok, c'est juste que l'intitulé de ce sujet est en anglais .

En gros pour simplifié il me manque juste cairo-dock-plug-ins-data (>= 2.1.2-4~debian
Donc, tu n'as pas téléchargé ce package ? . Bein télécharge-le dans le même dossier et répète la commande
dpkg -i *.deb

Sinon, pour les paquets :
  • CD dépend de CD-core et CD-plug-ins
  • CD-core dépend de CD-data + d'autres dépendances.
  • CD-data et CD-plug-ins-data n'ont pas de dépendances.
  • CD-plug-ins dépend de CD-plug-ins-data et CD-plug-ins-integration + d'autres dépendances.
  • CD-plug-ins-integration dépend de CD-plug-ins-data aussi.


PS : tu es certain que tu ne sais pas simplement ajouter les dépôts, ce serait nettement plus simple

Guest, Thursday 24 December 2009 à 14:23 | Quote

coucou, oui j'ai pas encore ajouter les dépots, et je n'ai encore jamais fait même si il explique très simplement sur le site officiel de Ubuntu ou sur votre site officiel Cairo-Dock. Mais pour l'instant j'ai pas internet sur mon pc portable et mes voisin son passé en CléWAP2, donc je reste pour l'instant dans l'égalité.

C'est good tout marche juste un petit détaille pour tout ce qui n'ont pas suivit :

Après avoir installer plug-in: rebooter votre pc
et Cairo-dock ce trouve pue dans accessoire mais dans outils système !

Voili voilou voila !

Merci qui ??? Merci a tout l'équipe ! Ainsi que a Matttbe ^^

Pour ca patience, et tout son temps.

[English] I repeat for setup if you haven't Lan in the web but manualy:

It's goog setup: You have juste download

this first:

cairo-dock_2.1.2-4-1ubuntu1
cairo-dock-data_2.1.2-4-1ubuntu1
cairo-dock-core_2.1.2-4-1ubuntu1

(warning: cairo-dock-dev_2.1.2-4-1ubuntu1 it's no important for setup Cairo-dock)

after for to have plug-in and widgets download:

cairo-dock-plug-ins-data_2.1.2-4-1ubuntu1
cairo-dock-plug-ins-integration 2.1.2-4-1ubuntu1    

And fore more packages for setup you must download in "www.packages.debian.org" and found ^^

Enjoye your Self every-body ! ^^

Thank Matttbe !

Fabio

matttbe, Thursday 24 December 2009 à 14:48 | Quote


Subscription date : 24 January 2009
Messages : 12573
I repeat for setup if you haven't Lan in the web but manualy:
Or simply follow this post => http://www.glx-dock.org/bg_topic.php?t=3794&pos=0#mess_49446 (just change the Ubuntu/Debian version )

For Debian users, you can find stable packages on the repository : http://repository.glx-dock.org/debian/dists/stable/pool/

Après avoir installer plug-in: rebooter votre pc
Pas besoin de redémarrer un pc ! Tu n'es pas sur Windows

Guest, Thursday 28 November 2013 à 21:57 | Quote

Hi!

I'm using Cairo-Dock, but sometimes it suddenly starts to eat up about 13% of my cpu cycles, and I have to kill (or quit) it, because cpu temperature starts to raise quickly. After that, I just cannot start Cairo-dock again (neither OpenGL nor non-GL), because it fires up imediately the cpu cycles draining. The only way it may run normally again is by rebooting the system. What's the matter? Any hints?

Cairo-dock v 3.0.0
Bodhi Linux x86_64
Kernel 3.8.0-12

Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
Installation problem for newbie without Internet connection
Page : 1 2
Sadeck English 21 Guest [Read]
29 November 2013 à 15:20

Post a message

Anti-spam filter 10 (*) times (*) 6 =
            
Did you know ? The Size tag can display your text in any size : [size=35][/size]


Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation Installation problem for newbie without Internet connection Top

Online users :

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.