Home Forums Wiki Doc Install Extras Screenshots Source Code Projects Blog Users Groups Register
Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation Cairo Dock 2.0SVN problems with X3100
The latest stable release is the *3.4.0* : How to install it here.
Note: We just switched from BZR to Git on Github! (only to host the code and your future pull requests)
Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
[Locked] Cairo Dock 2.0SVN problems with X3100
Page : 1 2 3 4
miau English 61 miau [Read]
31 July 2009 à 11:39

miau, Monday 27 April 2009 à 10:14


Subscription date : 27 April 2009
Messages : 38
Hello,

I installed Cairo-Dock on Arch of the AUR repository. When i start it with OpenGl Support, it doesn't work. When i start the dock sometimes it looks like this:

http://s10b.directupload.net/images/090427/fb2b8t4m.png

Sometimes it appears like this:

http://s10b.directupload.net/images/090427/5kxex2zo.png

And sometimes it works nearly normal after a minute, but some icons don't appear like they should be:

http://s11.directupload.net/images/090427/6dmzc4rd.png

When is start it with the Cairo Option the Dock works and shows like it is supposed to be.
Maybe anyone here can help me

Thank you in advance!

matttbe, Monday 27 April 2009 à 11:42


Subscription date : 24 January 2009
Messages : 12573
I think that the only responsible is your X3100 Intel card.
It seems that Xorg needs "UXA" for a good OpenGL support with Intel cards but it didn't work now on Ubuntu (it worked on a Alpha Jaunty release but not now...)
Maybe it works on Arch Linux (it depends of Xorg). If you want test it now, you can add this line on your "xorg.conf", section "Monitor" (make a backup !) :
Option "AccelMethod" "UXA"

But I advise you to wait a confirmation by another Intel card user.

fabounet, Monday 27 April 2009 à 11:42


Subscription date : 30 November 2007
Messages : 17118
it looks like a driver issue.
what kind of card have you ? if it's an ATI, you can give up on OpenGL until they make proper drivers.

Guest, Monday 27 April 2009 à 11:52

My card is an Intel X3100 and UXA is enabled in Xorg.conf. Driver Version of x86-video-intel is 2.6.3-3

Option "DRI" "true"
Option "AccelMethod" "UXA"
Option "FrameBufferCompression" "false"
Option "MigrationHeuristic" "greedy"
Option "XAANoOffscreenPixmaps" "true"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile GM965/GL960 Integrated Graphics Controller"
BusID "PCI:0:2:0"

miau, Monday 27 April 2009 à 11:54


Subscription date : 27 April 2009
Messages : 38
The above post was written by me...wasn't logged in.

miau, Thursday 30 April 2009 à 11:50


Subscription date : 27 April 2009
Messages : 38
i've tested ist als with driver version 2.7.99 ...still no change

matttbe, Thursday 30 April 2009 à 12:24


Subscription date : 24 January 2009
Messages : 12573
... Not easy with Intel or ATI card . Did you install property drivers ?

nochka85, Thursday 30 April 2009 à 12:45


Subscription date : 29 November 2007
Messages : 7408
Intel droped support of EXA and DRI1 in their new drivers -> http://www.phoronix.com/scan.php?page=news_item&px=NzIzNQ

matttbe, Thursday 30 April 2009 à 15:06


Subscription date : 24 January 2009
Messages : 12573

On April 29, 2009
Maybe the solution for Intel cards' user !

taiebot65, Saturday 02 May 2009 à 10:36


Subscription date : 26 October 2008
Messages : 1904
Oui on verra je suis sceptique maintenant si près du but et après tout casse. En tout cas faudra pas hesiter a rentrer tot dans le test de karmic car je crois qu'il faudra reporter des bugs sur mesa aussi... J attens apres l'UDS pour commencer a tester..

miau, Tuesday 05 May 2009 à 09:42


Subscription date : 27 April 2009
Messages : 38
Sorry, but I don't understand french

matttbe, Tuesday 05 May 2009 à 13:08


Subscription date : 24 January 2009
Messages : 12573
He said he is septic but when this news drivers is include in Karmic (Ubuntu 9.10), he will test it.

taiebot65, Tuesday 05 May 2009 à 13:21


Subscription date : 26 October 2008
Messages : 1904
Sorry i did not respond in english... I was the guy testing the intel drivers during the Jaunty update process. i can tell you that the alpha 6 was working better for intel cards than the final release... :'-|.
Cairo-dock opengl was usable.. Now it s a bloody mess.

I think it s too early for testing karmic koala because as Nochka said they dropped EXA support so too much crashes are going to be expected... But i will urge to test and report bug for intel drivers under karmic.. you will be able to use cairo-dock opengl as a good benchmark..

Me i m back with the normal display i m just using the plugins which are great...

miau, Wednesday 06 May 2009 à 17:13


Subscription date : 27 April 2009
Messages : 38
I'm using it also with the cairo option at the moment...i'll report when i find a solution.

miau, Thursday 07 May 2009 à 07:54


Subscription date : 27 April 2009
Messages : 38
It's working But everytime i start the dock i have to laod my theme. If not the graphical issues are there again...is there a switch to load a specific theme at startup?

miau, Thursday 07 May 2009 à 10:03


Subscription date : 27 April 2009
Messages : 38
Solved this problem by starting it with the indirect rendering option. All is working fine now

Mav, Thursday 07 May 2009 à 10:27


Subscription date : 29 November 2007
Messages : 3146
Could you please explain exactly what you did we will add it into the wiki

kawaji, Thursday 07 May 2009 à 12:29


Subscription date : 18 March 2008
Messages : 42
not X3100(GL960/GM965),
but I have tried with GMA3100(G31) and ubuntu jaunty default intel driver(2.6.3-0ubuntu9) ,UXA(DRI2).
UXA and Indirect-Rendering option seem to make the dock work.

Speed of rotate animation for icons is very slow, though.

I have just added one line into xorg.conf "device" section.
Option "AccelMethod" "UXA"


then, run cairo-dock with -i option.

Enabling UXA made also DRI2 automatically enabled.

I had been checking this ubuntu forum thread, http://ubuntuforums.org/showthread.php?t=1130582

and found this post, http://ubuntuforums.org/showpost.php?p=7202479&postcount=264

Actually if you are running the newer G31/35 and above series chip, all you have to do is to enable uxa in xorg, no need to update xorg or kernel, everything works fine, Google Earth, Penguin racer etc.


For older chipsets and other 9xx series Intel, you have no resort but to go the recommended way of changing kernel and driver and then applying mttr fix.


so, tried that by myself.

Mav, Thursday 07 May 2009 à 12:33


Subscription date : 29 November 2007
Messages : 3146
Could you please provide us which option you added into your xorg please

taiebot65, Thursday 07 May 2009 à 13:56


Subscription date : 26 October 2008
Messages : 1904
It all depends about the chipset of the drivers .... me UXA is unusable and it will not start the xserver...

I ve tried to start cairo-dock with -i options after selected opengl and i had a xorg crash

Installation problems | Problèmes à l'installation

Subjects Author Language Messages Last message
[Locked] Cairo Dock 2.0SVN problems with X3100
Page : 1 2 3 4
miau English 61 miau [Read]
31 July 2009 à 11:39


Glx-Dock / Cairo-Dock List of forums Installation problems | Problèmes à l'installation Cairo Dock 2.0SVN problems with X3100 Top

Online users : billsorry, xuezhiqian123, zhouyueyue,

Powered by ElementSpeak © 2007 Adrien Pilleboue, 2009-2013 Matthieu Baerts.
Dock based on CSS Dock Menu (Ndesign) with jQuery. Icons by zgegball
Cairo-Dock is a free software under GNU-GPL3 licence. First stable version created by Fabounet.
Many thanks to TuxFamily for the web Hosting and Mav for the domain name.